Samsung Droid Charge Forum

Support Youtube - Audio but no video?

Just got a charge. My first ever droid (been a blackberry user forever). So far, so good...still getting used to it.

One issue, I'm trying to watch videos on youtube but when I open any video (I've tried multiple), the video begins and I can HEAR it, but its just a black screen. Can someone tell me how to remedy this?


#1 TheVagueIdea, May 18, 2011
Hold power button down and select reset. Worked for me.
#2 burgs04, May 22, 2011
I am having this same issue, did the above do anything to fix it? where do you select reset?
There is a restart option, not reset.
#3 Stallard, Jun 3, 2011
I was having the same problem. Stallard, I think burgs04 meant RESTART instead of RESET. I selected RESTART and it seemed to do the trick.
#4 UllieBully, Jun 6, 2011
That worked one time, but did it again after that. It is working now with the EE4 update, hope it keeps working.
#5 Stallard, Jun 13, 2011
I still get the same issue. It's like after a few hours the phone acts stupid. It won't recognize mp3s either so i won't hear my phone ring or custom sms mp3 sounds either unless i restart
#6 PapaBearBaloo, Jun 15, 2011
I made this quick video summarizing the issues we are seeing here. If you can, please distribute it to people and maybe we can gain some attention. This is driving me nuts!

YouTube - ‪Droid Charge Media Issue‬‏
#7 Yankees368, Jun 16, 2011
I had the same problem with my Droid Charge and finally figured out how to resolve the problem. It appears to be an issue with the official Twitter app. After I uninstalled it and restarted the phone, I've never had the problem. This resolved the issue with YouTube playing back with no video and just audio, the issue with music not playing from the Music Player, and video's not playing on the Video Player. I thought I would share what worked for me. Good luck.
#8 mrjwen, Jun 26, 2011
Oops, forgot to repost here! The solution has been in the youtube video for a while.
Yea, removing the official Twitter app solves this issue.
Weird and annoying.
#9 Yankees368, Jun 26, 2011
Thanks for posting that video and the resolution! I had missed it, but glad we were both able to resolve the issue. It was driving me crazy.
#10 mrjwen, Jun 26, 2011
Yea, the is pretty unacceptable for a Droid branded phone. However, it seems to affect all Galaxy S phones, not just the Charge. I'm kind of surprised how this issue is being ignored by all involved and the android media sites.
#11 Yankees368, Jun 26, 2011
I've had my Charge for a few weeks and noticed this as well, but I'm an avid Twitter user, can I re-install Twitter now, or what? Thanks for the help!
#12 abbey.f, Jul 9, 2011
Nope. You must use a third-party app like Tweetdeck or Tweet Caster Pro.
#13 Yankees368, Jul 10, 2011
Twitter just issued a big update today. Anyone else willing to install it and see if it no longer breaks our phones?
#14 Yankees368, Jul 13, 2011
I tried it out, still broke video (but maybe not audio). AGH!
#15 Yankees368, Jul 13, 2011
Finally got word out of Samsung about this today:
"We are working on a fix. Thank you! ^JB"
#16 Yankees368, Jul 21, 2011
Yet another Twitter update today. Anyone try it?
Buried in the change log says "Some devices lose the ability to play media files. If you are still experiencing this issue after the update, please disable the option for sound effects in the app settings."

Come on people, lets give this a try!
EDIT 2: Real response from twitter:
What you are experiencing is a known Issue. Good news is that we recently released an update and the issue is now fixed. To find out more about this issue, check out this article:
For information about the latest update and where to get it, go here:
If you are still experiencing this issue after upgrading, please let us know! Otherwise, have a great day!
#17 Yankees368, Jul 27, 2011
Exactly what my phone is doing...this is getting incredibly frustrating.
Update: Uninstalled twitter and restarted...Will does this fix the unable to play mp3 issue as well?
#18 Notaneggspert, Aug 21, 2011
It should, but this issue was resolved with the last twitter app update
(make sure that you have sound effects turned off in the twitter app)
#19 Yankees368, Aug 22, 2011
I'm having the same YouTube problem, but I don't use Twitter.
#20 colmack, Sep 5, 2014