Nexus 5 Forum

Root [Solved]Adb sideload returns error.

I was going to sideload a ROM until I discovered that my adb server keeps returning a "error: closed" message. I used Google's SDK tools so adb is up to date. I'm running on windows 8.1. Tried killing the server but its no good. Have twrp


#1 Incakola, Dec 6, 2014 Last edited: Dec 6, 2014
Have you tried the following?
Did you rename the ROM to ""? (Without the quotes)
Also some times when you rename the file, sometimes Windows will automatically add a .zip to the file extension... So it ends up being if so remove the extra .zip and try it again.
Try doing it all through adb commands -
Open the command prompt from the directory of where the ROM and the adb.exe is located on your PC (Platform tools) and type the command: "adb reboot recovery" (without the quotes)
Then select “apply update from adb”
Using the command prompt type: "adb sideload" (without the quotes) The file should then load and the ROM update will start.
When completed, select reboot system.
#2 xdrc45, Dec 6, 2014
After trying once more I figured it's got to be a problem with the adb driver.

I don't recall having to type twice in cmd because of renaming it. Once I access the recovery adb it somehow disconnects my device.
C:\Users\-\Downloads\ANDROID\sdk\platform-tools>adb devices
List of devices attached
******************* recovery

after initiating adb sideload in recovery:

C:\Users\-\Downloads\ANDROID\sdk\platform-tools>adb devices
List of devices attached
Fixed outcome:
C:\Users\-\Downloads\ANDROID\sdk\platform-tools>adb devices
List of devices attached
****************** sideload

C:\Users\-\Downloads\ANDROID\sdk\platform-tools>adb sideload
serving: '' (~94%) * failed to read command:
(blank flash zip)
#3 Incakola, Dec 6, 2014
#4 mistik146, Jun 13, 2015
Try updating to the latest TWRP fwiw.

A lot of people can't get this working - while a lot can.

I recently surveyed staff to try this and most couldn't get it to work.

I approached one of TWRP devs and he couldn't get his to not work.

The problem is operating system dependent and even configuration dependent on Windows.

Until we get broken and working machines side by side to track down the problem it's a good bet that this won't get fixed from either side.

What will work on most phones is an inexpensive OTG USB cable and a USB stick formatted with FAT32.

Btw, to see your files in the command window to check the zip zip thing just say -

#5 EarlyMon, Jun 13, 2015
I'm on windows 8.1 and I had to disable the unnecessary driver security feature implemented in windows 8. Rebooted computer into windows recovery and disabled driver security under advance settings. Then I reinstalled my drivers (pdanet was always my preferred driver for windows 8). If all else fails, try EarlMon's advice.
#6 Incakola, Jun 14, 2015