Samsung Galaxy S3 Forum

Support NFC will not turn on

Hey everyone. My girlfriends Samsung Galaxy S3 is having some issues with the NFC feature. First off the phone is unmodded and not rooted. NFC will not switch to ON at all. When you slide it over to ON it just springs back to OFF. You can switch S Beam to ON but not the NFC. Because of this we cannot share pictures with her S3 to my S3. The phone has the original OEM battery in it as well. (I read the batt can be an issue) So I swapped my known good battery into her phone and it still doesnt work. The phone has the most up to date firmware. Tried uninstalling some apps, tried rebooting etc. Still no luck. What other things can I try? Everything else on the phone seems to be working fine but the NFC


#1 Juiced46, May 26, 2013
By "Known good battery" do you mean a battery that you have actually used NFC successfully with? The NFC antenna is in the battery so you could have a "good" battery (5 volts) without having a good NFC.

But even a non-NFC battery should NOT cause the NFC toggle to switch back. So I doubt that's it. I've had a non-NFC battery in my S3 and while the NFC doesn't work, it has no effect on the switch.

My guess is that you are running some profile software such as Llama (my favorite), Tasker, Chronos, Locale, Smart Places, or Easy Profile. These apps change settings depending on a condition (or conditions) you set (e.g. a specific location, on battery charge, within wifi coverage, etc.).

It sounds like you have one of these which is triggering "NFC OFF."
#2 Johnny Cakes, May 26, 2013
Thanks for the reply. The known good battery, NFC works successfully with in the phone that it came out of. So we ruled out the battery.

She has none of those apps installed on her phone. Actually very few. Just some games like candy crush, angry birds, Bank of America app and a few other games.

NFC used to work on the phone then all of a sudden it stopped. I do not know what else to do aside from deleting all apps one by one. Or maybe a backup and reset?
#3 Juiced46, May 26, 2013
Did you ever resolve this issue? My girlfriend is having the exact same issue, and I have tried all the same potential remedies to no avail. If you have a solution, I'd love to hear it!
#4 weaslyd, Jun 30, 2013
No I have not. There was a new software update. That didnt fix it. Probably going to resort to a factory reset soon.
#5 Juiced46, Jun 30, 2013
We just bought a Galaxy S3 for my wife and NFC will not turn on. I have had mine for over a year and everything works great. So when I went to turn on NFC on her phone and it wouldn't stay on, it took me by surprise.

This is stock 4.1.2 and unrooted. She has just a few apps installed so I don't think it would be that.

We swapped batteries. Her battery works fine in my phone, NFC stays on. With my battery in her phone, NFC does the same thing.

So, what could be going on?
#6 realjag, Jul 20, 2013
i have the same issue. it will work sometimes, and not others

have done a reset twice to try and resolve this
#7 FxsX24, Jul 22, 2013
I'm also having this problem. Any luck finding a solution?
#8 SethK, Sep 20, 2013
Unfortunately this will not help un rooted/non CMW recovery phones but will work for any rooted /CMW recovery I9300 phones with the issue.
Flash via CMW wipe cache wipe dalvik re boot.
#9 chazey2, Sep 21, 2013
Thanks for the post Chazey.

Bumping this for any help with this in general.
#10 SethK, Dec 24, 2013