Nexus 4 Forum

Root Help!Failed to unlock Bootloader~~~~~

I just got my Nexus 4 and installed SDK and drivers on PC. OK, so now I boots my phone into fastboot mode, I connected it to my PC, entered"fastboot devices" in command line, no problem, I can see the device with the ID.

But when I entered"fastboot oem unlock", the command line it says" FAILED <command write failed <Unknown error>>". And the phone stays in fastboot mode without any pop-up.

I tried to factory set the phone, restart computer and phone, change to another computer, none of them worked.

Any help is deeply appreciated. :(

Update: I use USB 2.0 ports on the backside of the computer. Also USB 2.0 on my laptop. Changed three USB cables. None of them work.

Update 2: contacted Google customer service, seems that the phone is defective.

This is what happened when I entered recovery mode from bootloader.


#1 w20031424, Apr 12, 2013
Out of curiosity, are all the ports that you tried all usb 1.0 or usb 3.0 ports? If so, the sdk is kind of flaky with those and it's recommended using usb 2.0 ports.
#2 jhawkkw, Apr 12, 2013
Did you get an output of

1234567890ABC123 (example of serial #) device

when you typed the fastboot devices command?

Edit: Never mind, you stated that already.

Hmm...thinking... BRB.

What about trying the mini-sdk?

Let me find it.
#3 jmar, Apr 12, 2013
Nah.. all of them are USB 2.0. I tried like four or five ports. But thank you.
#4 w20031424, Apr 12, 2013
I installed the full SDK from Google website, also tried a 1.25 MB mini-SDK. Tried Wugs Nexus 4 Root Toolkit, stuck at the fastboot page without popping up unlocking option, which I assume had the same issue.
#5 w20031424, Apr 13, 2013
What about a different USB cable? I'm just as perplexed as you are, especially since you got the proper output after typing the fastboot devices command. Out of curiosity, what happens when you type fastboot oem lock?

Gonna see if I can get a buddy of mine to pop in here. He is a Nexus guru.
#6 jmar, Apr 13, 2013
I stated that in the original post,

"But when I entered"fastboot oem unlock" command line , it says" FAILED <command write failed <Unknown error>>". And the phone stays in fastboot mode without any pop-up."

I changed several cables, and no avail.

But thanks anyway. I hope your friend can help me.
#7 w20031424, Apr 13, 2013

I would have suggested exactly what jhawkkw, jmar, and you have already discussed and tried (different USB ports (2.0) and different cables).

I have indeed seen the same behavior has you reported with the "command write failed" when I used a USB 3.0 port with fastboot on my GNex way back when I first got it (a 2.0 port solved the issue), although it was on a fastboot flash command and not during the unlock (which I'm guessing only transfers a small amount of data).

If it were unlocked, you could try some other commands to pull data via fastboot, but that's probably a non-starter now :(.

Testing a large data transfer with adb (an adb pull or push) might also re-inforce what you are seeing, but still wouldn't solve the unlocking issue you're having with fastboot.

Since you've ruled those two things out, I think you've also already done the next logical thing in contacting Google.

Let us know what happens later (i.e., if a new device is issue-free).

Cheers and best of luck!
#8 scary alien, Apr 13, 2013
I think I remember seeing an article that allowed you to unlock without data wiping on the Nexus 4 & Nexus 10, which I assumed meant workout using fastboot. I'm not home at the moment, but when I get home I'll try and locate it. Unless someone find it first.
#9 jhawkkw, Apr 13, 2013
:) Thanks. I do find such an app on Google Play, but it requires Root access, which is a catch-22 for me.

You need to hurry if you plan to do so, Google already ships out the new replace phone.:D
#10 w20031424, Apr 13, 2013
Yep, I just honestly told them that I could not unlock the phone and the stock recovery seemed broken, then they agreed to give me a new one for free as long as I return this one with their prepaid-UPS-label. :rolleyes:

The interesting thing is the new phone will come with a $299 price without shipping fee or taxes, which will be refunded once they received my defective one, which also means, I can actually buy a new one without shipping fee or tax if I can fix the present one. A small loophole I guess. ;)

It says like this
"You do not pay for the replacement device; however, your payment method will be authorized for the full amount of the device when you place your replacement order. You will not be charged if we receive your original device within 21 days from the date you order your replacement device. "
#11 w20031424, Apr 13, 2013
That would be the 8gb version?
That would be very very cool if you could get the 16gb version for that price.:D

Someone suggested this earlier (but you misunderstood him) go into fastboot and type fastboot oem lock
You tried UNLOCK it may not make a difference though.
can you use the fastboot method to install a temp recovery, then in recovery flash the superuser zip?

That would give you root to attempt that other method you mention.
Or even try install permanent recovery?
#12 new optimus, Apr 13, 2013
Yeah, that does seem to be the case. So far, I have not found any way to root the nexus 4 without unlocking. Most devs probably don't bother looking for such an exploit because there usually isn't a need. I know on the Galaxy Nexus there were ways initially, but eventually those methods died as well. At least you're getting a replacement though. Hopefully this one will cooperate more.
#13 jhawkkw, Apr 13, 2013
Yeah, it's 8GB. fastboot oem lock also returns the same failure result. I tried to flash a custom recovery using the fastboot flash recover recovery.img command, but it says "Error: can not load recovery.img" , although I placed the file in the root and named it "recovery.img."
#14 w20031424, Apr 13, 2013